On Tue, Mar 03, 2015 at 05:30:34PM -0800, Daniel Frey wrote
> On 03/03/2015 10:06 PM, Walter Dnes wrote:
> >   And a "lib" is not necessarily always a direct dependancy.  E.g. my
> > HDHomerun OTA TV tuner requires the media-libs/libhdhomerun ebuild to be
> > explicitly installed.
> > 
> Wait, really? I've had mine since 2010 and I've never had that package
> installed (media-libs/libhdhomerun). MythTV detected and used it without
> complaints. Or is it required for other programs?
> I just tried genlop and it is saying I've never had any version of
> libhdhomerun installed.

  /usr/portage/distfiles/libhdhomerun_20140121.tgz is all of 47,685
bytes.  It provides a ***COMMAND LINE INTERFACE***.  I happen to be a
"command line commando""  Using that command line interface, I've rigged
up a bash script and a text config file that allows me to fire up the
local CBC station, on tuner 0, with the command...

tv 0 cbc

Similarly, I can launch the local CTV station with the command

tv 0 ctv

  The other option is to "save 47,685 bytes" and emerge MythTV instead

USE="mysql" emerge -pv mythtv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libogg-1.3.1  USE="-static-libs" 398 KiB
[ebuild  N     ] dev-libs/libaio-0.3.110  USE="-static-libs {-test}" 42 KiB
[ebuild  N     ] media-libs/xvid-1.3.3  USE="threads -examples -pic" 0 KiB
[ebuild  N     ] media-fonts/liberation-fonts-2.00.0-r1  USE="X -fontforge" 
2,249 KiB
[ebuild  N     ] app-admin/eselect-qtgraphicssystem-1.1.1  2 KiB
[ebuild  N     ] media-libs/libmp4v2-2.0.0  USE="-static-libs {-test} -utils" 
485 KiB
[ebuild  N     ] dev-perl/TermReadKey-2.300.200-r1  37 KiB
[ebuild  N     ] dev-perl/Net-Daemon-0.480.0-r1  29 KiB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.320.0-r2  0 KiB
[ebuild  N     ] virtual/perl-Time-HiRes-1.972.500-r3  0 KiB
[ebuild  N     ] virtual/perl-Term-ANSIColor-4.20.0-r2  0 KiB
[ebuild  N     ] virtual/perl-Getopt-Long-2.390.0-r1  0 KiB
[ebuild  N     ] dev-qt/qtcore-4.8.5-r2:4  USE="exceptions glib ssl (-aqua) 
-debug -iconv -icu -pch -qt3support" 235,832 KiB
[ebuild  N     ] media-libs/libvorbis-1.3.4  USE="-static-libs" 1,066 KiB
[ebuild  N     ] media-libs/taglib-1.9.1-r2  USE="asf mp4 -debug -examples 
{-test}" 639 KiB
[ebuild  N     ] media-sound/lame-3.99.5-r1  USE="-debug -mp3rtp -sndfile 
-static-libs" CPU_FLAGS_X86="(-mmx)" 568 KiB
[ebuild  N     ] x11-misc/wmctrl-1.07-r1  86 KiB
[ebuild  N     ] media-libs/faac-1.28-r4  USE="-static-libs" 663 KiB
[ebuild  N     ] x11-libs/libXinerama-1.1.3  USE="-static-libs" 272 KiB
[ebuild  N     ] dev-db/mysql-init-scripts-2.0-r1  0 KiB
[ebuild  N     ] dev-perl/PlRPC-0.202.0-r2  18 KiB
[ebuild  N     ] dev-qt/qtscript-4.8.5:4  USE="exceptions jit (-aqua) -debug 
-iconv -pch" 0 KiB
[ebuild  N     ] dev-qt/qtdbus-4.8.5:4  USE="exceptions (-aqua) -debug -pch" 0 
[ebuild  N     ] media-libs/libtheora-1.1.1-r1  USE="encode -doc -examples 
-static-libs" 1,859 KiB
[ebuild  N     ] dev-qt/qtxmlpatterns-4.8.5:4  USE="(-aqua) -debug -pch" 0 KiB
[ebuild  N     ] dev-perl/DBI-1.628.0  USE="{-test}" 573 KiB
[ebuild  N     ] dev-qt/qtgui-4.8.5-r3:4  USE="accessibility exceptions glib xv 
(-aqua) -cups -debug -egl -gtkstyle -mng -nas -nis -pch -qt3support -tiff 
-trace -xinerama" 51 KiB
[ebuild  N     ] dev-qt/qtwebkit-4.8.5:4  USE="exceptions jit (-aqua) -debug 
-gstreamer -icu -pch" 0 KiB
[ebuild  N     ] dev-qt/qtopengl-4.8.5:4  USE="exceptions (-aqua) -debug -egl 
-pch -qt3support" 0 KiB
[ebuild  N     ] dev-db/mariadb-10.0.15-r1  USE="bindist community perl ssl 
-cluster -debug -embedded -extraengine -jemalloc -latin1 -minimal -odbc 
-oqgraph -pam -profiling (-selinux) -sphinx -static -static-libs -systemtap 
-tcmalloc {-test} -tokudb -xml" 55,691 KiB
[ebuild  N     ] virtual/mysql-5.6-r2:0/18  USE="-embedded -minimal -static 
-static-libs" 0 KiB
[ebuild  N     ] dev-perl/DBD-mysql-4.20.0-r1  USE="-embedded" 135 KiB
[ebuild  N     ] dev-qt/qtsql-4.8.5:4  USE="exceptions mysql sqlite
(-aqua) -debug (-firebird) -freetds -oci8 -odbc -pch -postgres -qt3support" 0 
[ebuild  N     ] media-tv/mythtv-0.27_p20140321  USE="hls theora vorbis xml 
xvid -alsa (-altivec) -autostart -bluray -cec -crystalhd -debug -dvb -dvd -egl 
-fftw -ieee1394 -jack -lcd -libass -lirc -perl -pulseaudio -python -raop -vaapi 
-vdpau -xmltv" INPUT_DEVICES="-joystick" 84,182 KiB

total: 34 packages (34 new), Size of downloads: 384,869 KiB

  No thanks.

Walter Dnes <waltd...@waltdnes.org>
I don't run "desktop environments"; I run useful applications

Reply via email to