On 15 September 2016 01:01:02 CEST, Rich Freeman <ri...@gentoo.org> wrote:
>If you're using an initramfs the kernel will not mount anything at any
>time unless some process with sufficient capabilities asks it to.  The
>initramfs typically mounts the root partition, and then execs init.
>Anything beyond that is done by init or whatever processes it spawns,
>such as openrc.  Offhand I don't remember if modern initramfs
>solutions mount root as read-write; openrc will probably check for
>this in any case and remount if it is read-only (I could be wrong on
>that).
>
>If something other than root isn't mounted correctly, the fault
>probably lies in your fstab or openrc, or you're missing a necessary
>driver/etc.

Thanks for correcting me, i mixed it up a bit. But after looking in into the 
init-system I found the problem (or at least I fixed it).

Since the init did not work I tried:
# openrc sysinit

and got some errors I can not fully recall. So I took a look at dmesg (needed 
to use the command, since the file did not get created) I saw: the problem was 
a segfault in libselinux. I switched to the live-cd mounted all partitions 
chrooted in it, then I reemerged the whole system (emerge -ae world), because I 
wanted to be sure to go safe. After this I double checked the kernel 
configuration again and rebuild it as well (the same with the initramfs). This 
solved the problem, at least for me (finally I have the right keyboardlayout 
loaded on boot ;-).

Thanks for all your help pointing me in the right direction (especially with 
/proc/mounts which cleared the way). I learned quite a lot and got my system 
running the I want.





Holger Wünsche

Reply via email to