On Monday 19 Sep 2016 21:28:25 Mick wrote:
> On Monday 19 Sep 2016 13:08:29 Mike Gilbert wrote:


> > The manpage seems to be incorrect; -B/--delete-bootnum does not take
> > any argument. Instead, you must specify the entry number using the -b
> > option.

Or you could say, with hindsight, that the man page is not strictly 
incorrect, as it doesn't say anything that isn't true. You just have to know 
how to interpret it before you start.   :)

> > Try this:
> > 
> > efibootmgr -b 0001 -B

That worked a treat - many thanks. Except for this little wrinkle, which I 
hope is harmless:

# efibootmgr -b 0000 -B
BootCurrent: 0002
Timeout: 1 seconds
No BootOrder is set; firmware will attempt recovery
Boot0002* Linux Boot Manager
Boot0008  CD/DVD Drive 
Boot0010* UEFI OS

> I recall having a similar problem and this worked last time I tried:
> efibootmgr -b 0002 --delete-bootnum Boot0002
> where:
> -b 002
> is the entry I want to modify.
> --delete-bootnum Boot0002
> is what I want to do to it.  I don't remember if specifying "Boot0002" was
> necessary, but it worked all the same.  I guess you can try first:
> efibootmgr -b 0001 -B
> as already suggested and see if this does it.  Also, before I delete a
> boot stub entry, e.g. 0002, I change the boot order to make sure it is
> not first: --bootorder 0003,0005,0010,0002
> but I don't think it is necessary.

Hah! Watch this:

# efibootmgr --bootorder 0002,0010,0008
Could not set BootOrder: No space left on device

I'll do a bit more poking around.


Reply via email to