Franz Fellner wrote:
> Adding "--verbose --tree" to your emerge options probably reveals the 
> offending package.
> It is likely this is caused by a dependency you have not yet masked.
> Meld master already contains fixes for those issues, so hopefully they 
> release a fixed
> version soon...
> On Wed, 21 Sep 2016 10:30:21 +0200, Raffaele BELARDI 
> <> wrote:
>> I have masked >gtk+-3.18.9 due to issues with meld on my system [1],[2].
>> Today's update wants me to unmask it [3]. Checking the ebuilds, none of
>> the packages emerge lists should need a gtk+ higher than gtk+-3.18.9;
>> for example the most probable candidate, gcr-3.20.,0 depends only on:
>>         >=app-crypt/p11-kit-0.19
>>         >=dev-libs/glib-2.38:2
>>         >=dev-libs/libgcrypt-1.2.2:0=
>>         >=dev-libs/libtasn1-1:=
>>         >=sys-apps/dbus-1
>>         gtk? ( >=x11-libs/gtk+-3.12:3[X,introspection?] )
>>         introspection? ( >=dev-libs/gobject-introspection-1.34:= )
>> Also none of the installed packages needs it [4].
>> Any way I can convince emerge to proceed with the update without
>> unmasking gtk+-3.20.x?

Good suggestion, thanks. notification-deamon wants the upgrade, I'll try 
with some more masking or USE change.

Do you have a reference regarding the meld issue so I can track it?



[nomerge       ] media-sound/ario-1.5.1-r1::gentoo  USE="dbus idle 
libnotify nls -audioscrobbler -debug -python -taglib -zeroconf"
[nomerge       ]  x11-libs/libnotify-0.7.6-r3::gentoo 
USE="introspection {-test}"
[nomerge       ]   virtual/notification-daemon-0::gentoo  USE="-gnome"
[ebuild     U  ]    x11-misc/notification-daemon-3.20.0::gentoo 
[3.18.2::gentoo] 333 KiB

[nomerge       ] x11-misc/notification-daemon-3.20.0::gentoo 
[ebuild     U #]  x11-libs/gtk+-3.20.9:3::gentoo [3.18.9:3::gentoo] 
USE="X introspection (-aqua) -broadway -cloudprint -colord -cups 
-examples {-test} -vim-syntax -wayland -xinerama (-debug%)" 16,773 KiB

Reply via email to