Have any of you seen this before?  This is on a fresh install.  I can't
get anything GNOME-based to install as it looks like gnome-keyring is
bringing in an older version of gtk+ which somehow depends on
gtk-engines-adwaita which in turn depends on gtk+.

* Profile: gnome/systemd
* No additional USE flags.

# emerge -auDN --keep-going --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

[nomerge       ] app-crypt/libsecret-0.18.5::gentoo  USE="crypt
introspection -debug {-test} -vala"
[nomerge       ]  gnome-base/gnome-keyring-3.20.0::gentoo  USE="caps
filecaps pam ssh-agent (-selinux) {-test}"
[nomerge       ]   app-crypt/pinentry-0.9.7-r1::gentoo 
USE="gnome-keyring gtk ncurses -caps -emacs -qt4 -qt5 -static"
[nomerge       ]    x11-libs/gtk+-2.24.31-r1:2::gentoo
[3.20.9:3::gentoo] USE="introspection vim-syntax (-aqua) -cups -examples
{-test} -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     x11-themes/gtk-engines-adwaita-3.20.2::gentoo 
ABI_X86="(64) -32 (-x32)" 2,812 KiB
[ebuild  NS    ]      x11-libs/gtk+-2.24.31-r1:2::gentoo
[3.20.9:3::gentoo] USE="introspection vim-syntax (-aqua) -cups -examples
{-test} -xinerama" ABI_X86="(64) -32 (-x32)" 12,506 KiB
[ebuild  N     ]   app-crypt/gnupg-2.1.15::gentoo  USE="bzip2 gnutls nls
readline usb -doc -ldap (-selinux) -smartcard -tofu -tools" 5,590 KiB
[ebuild  N     ]    app-crypt/pinentry-0.9.7-r1::gentoo 
USE="gnome-keyring gtk ncurses -caps -emacs -qt4 -qt5 -static" 423 KiB
[ebuild  N     ]  gnome-base/gnome-keyring-3.20.0::gentoo  USE="caps
filecaps pam ssh-agent (-selinux) {-test}" 1,187 KiB
[nomerge       ] sys-apps/openrc-0.22.2::gentoo  USE="ncurses netifrc
pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs -tools"
[ebuild   R    ]  sys-auth/pambase-20150213::gentoo  USE="cracklib
gnome-keyring* nullok sha512 systemd (-consolekit) -debug -minimal
-mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux)" 4 KiB

Total: 6 packages (4 new, 1 in new slot, 1 reinstall), Size of
downloads: 22,519 KiB

 * Error: circular dependencies:

(x11-libs/gtk+-2.24.31-r1:2/2::gentoo, ebuild scheduled for merge)
depends on
 (x11-themes/gtk-engines-adwaita-3.20.2:0/0::gentoo, ebuild scheduled
for merge) (runtime)
  (x11-libs/gtk+-2.24.31-r1:2/2::gentoo, ebuild scheduled for merge)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

Reply via email to