On Wed, Jan 31, 2018 at 2:58 PM, Magnus Johansson <gen...@rnd.se> wrote:
> I've got a fresh Gentoo installation that does not boot. I just end up in
> the Grub2 shell.
> However when there if I do 'set root=(md/0)' and 'configfile /grub/grub.cfg'
> I do get to the Grub2 menu where Gentoo boots just fine.
> /boot and / are both on mdadm devices.
> I've tried re-running grub-mkconfig and grub-install several times without
> luck.
> I've added domdadm to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub.
> Drives sda/sdb use GPT disklabels and have 20M BIOS boot partitions first.

To which device are you installing grub?

Check what "core.img" prefix and modules grub-install is using with

grub-install --debug $your_device 2>&1 | grep grub-mkimage

[I hit a similar problem with mdadm 6 or 7 years ago and had to create
a custom "core.img" to boot normally. You might have to do the same
but i would've thought that this problem's been solved. I haven't
encountered it since.]

Reply via email to