On Wed, 07 Mar 2018 15:52:24 +0100
Christoph Böhmwalder <christ...@boehmwalder.at> wrote:
I think I broke something once again...

Rebooting after a recent update caused my X Server to completely die.  I
faintly remember some x11-related packages being blocked on that
particular update, but because I was short on time I decided just to
ignore those at the time (note to self: bad idea, apparently).

Now when I run startx, it complains about a bunch of permissions being

$ cat Xorg.0.log
---- 8< ----
[    11.763] (--) using VT number 7

[    11.763] (EE)
Fatal server error:
[    11.766] (EE) xf86OpenConsole: Cannot open virtual console 7 (Permission 
[    11.767] (EE)
[    11.768] (EE)
Please consult the The X.Org Foundation support
        at http://wiki.x.org
for help.
[    11.773] (EE) Please also check the log file at 
"/home/christoph/.local/share/xorg/Xorg.0.log" for additional information.
[    11.774] (EE)
[    11.775] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
[    11.775] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
[    11.775] (EE) Server terminated with error (1). Closing log file.

(I'll attach the full log)

I don't fully understand what's going on there, but I figured maybe
someone more experienced on here might have an idea as to what I did
wrong this time.

FWIW, I already tried setting the permissions of /dev/tty7 to 664,
causing the X server to work, albeit with inputs not working (the log
reveiled that it couldn't access /dev/input/event7 or something, so
probably the same issue).

My user's groups are:

$ groups christoph
tty wheel audio video usb users input davfs2 plugdev christoph kvm

(Note tty, audio, video, and input. That's all X should really need,

My VIDEO_CARDS contains "intel i915" (for an Intel HD 4000(?) chip in a
Lenovo X1 Carbon 1st gen).

Has this broken for anyone else?  Anyone who could point me in the right
direction?  Thanks in advance!

I got the same (again) but x11-base/xorg-server- runs just fine here when, and only when, I re-implement the +suid USE-flag (--enable-install-setuid) and remove --enable-suid-wrapper from the ebuild.

Remove your user from tty group and you’ll probably get:

   “parse_vt_settings: Cannot open /dev/tty0 (Permission denied)”

that is discussed at [1]. So downgrading to:


may be a quick but cannot be a permanent solution in my opinion.

  - [1] <https://bugs.gentoo.org/show_bug.cgi?id=635102>


Reply via email to