I got two problems, which have to do woth "sound" ... more or less.

First one: The vivaldi browser does not produce any audio...
The Vivaldi support page says (for Ubuntu) one had to install a
certain ffmpeg package, which is - namewise - related to chromium.

Since there is a USE flag "chromium" for ffmeg, I installed this:
[I] media-video/ffmpeg
     Available versions:  3.2.6(0/55.57.57)^d (~)3.2.7(0/55.57.57)^d 
3.3.4(0/55.57.57)^d 3.3.5(0/55.57.57)^d 3.3.6(0/55.57.57)^d 
(~)3.4.2(0/55.57.57)^d [m]**9999(0/56.58.58)^d {X alsa altivec amr amrenc 
appkit armv5te armv6 armv6t2 armvfp bluray bs2b +bzip2 cdio celt chromaprint 
chromium cpudetection debug doc ebur128 +encode fdk flite fontconfig frei0r 
fribidi gcrypt gme gmp gnutls +gpl gsm +hardcoded-tables +iconv iec61883 
ieee1394 jack jpeg2k kvazaar ladspa libass libcaca libdrm libilbc librtmp 
libsoxr libv4l lzma mipsdspr1 mipsdspr2 mipsfpu mmal modplug mp3 neon +network 
nvenc openal opengl openh264 openssl opus oss pic +postproc pulseaudio 
rubberband samba schroedinger sdl snappy sofalizer speex ssh static-libs svg 
test theora +threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack webp 
x264 x265 xcb xvid zeromq zimg +zlib zvbi ABI_MIPS="n32 n64 o32" ABI_PPC="32 
64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_ARM="neon thumb thumb2 v6 v8 
vfp vfpv3" CPU_FLAGS_X86="3dnow 3dnowext aes avx avx2 fma3 fma4 mmx mmxext sse 
sse2 sse3 sse4_1 sse4_2 ssse3 xop" FFTOOLS="+aviocat +cws2fws +ffescape +ffeval 
+ffhash +fourcc2pixfmt +graph2dot +ismindex +pktdumper +qt-faststart +sidxindex 
     Installed versions:  3.4.2(0/55.57.57)^d(11:42:45 AM 03/11/2018)(X alsa 
bzip2 chromium encode fdk gpl hardcoded-tables iconv jack jpeg2k mp3 network 
postproc sdl threads v4l vdpau vorbis x264 x265 zlib -altivec -amr -amrenc 
-appkit -bluray -bs2b -cdio -celt -chromaprint -cpudetection -debug -doc -flite 
-fontconfig -frei0r -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 
-kvazaar -ladspa -libass -libcaca -libdrm -libilbc -librtmp -libsoxr -libv4l 
-lzma -mipsdspr1 -mipsdspr2 -mipsfpu -mmal -modplug -nvenc -openal -opengl 
-openh264 -openssl -opus -oss -pic -pulseaudio -rubberband -samba -snappy 
-speex -ssh -static-libs -svg -test -theora -truetype -twolame -vaapi -vpx 
-wavpack -webp -xcb -xvid -zeromq -zimg -zvbi ABI_MIPS="-n32 -n64 -o32" 
ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_ARM="-neon 
-thumb -thumb2 -v6 -v8 -vfp -vfpv3" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext 
sse sse2 sse3 -aes -avx -avx2 -fma3 -fma4 -sse4_1 -sse4_2 -ssse3 -xop" 
FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot 
ismindex pktdumper qt-faststart sidxindex trasher")
     Homepage:            http://ffmpeg.org/
     Description:         Complete solution to record, convert and stream audio 
and video. Includes libavcodec


[I] www-client/vivaldi
     Available versions:  1.14.1077.55_p1^md {L10N="+am +ar +bg +bn +ca +cs +da 
+de +el +en-GB +en-US +es +es-419 +et +fa +fi +fil +fr +gu +he +hi +hr +hu +id 
+it +ja +kn +ko +lt +lv +ml +mr +ms +nb +nl +pl +pt-BR +pt-PT +ro +ru +sk +sl 
+sr +sv +sw +ta +te +th +tr +uk +vi +zh-CN +zh-TW"}
     Installed versions:  1.14.1077.55_p1^md(11:06:12 AM 03/11/2018)(L10N="am 
ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi hr hu id 
it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th 
tr uk vi zh-CN zh-TW")
     Homepage:            http://vivaldi.com/
     Description:         A new browser for our friends

but with no success.

I use alsa and jackd - no pulseaudio and such.

Searching for "gentoo vivaldi no sound" gave my a couple of links,
which all mention the ubuntu package mentioned above.

What can I do Gentoo-like to enable audio with Vivaldi ?

Second problem is a little spooky:
(Previously this has worked without problems...)

When I start qjackctrl, the mouse buttons and keyboard get disabled.
Caps-Lock still switches the LED and the cursor is still moving.

I have installed this:
[I] media-sound/qjackctl
     Available versions:  0.4.5 {alsa dbus debug portaudio}
     Installed versions:  0.4.5(12:12:35 PM 03/11/2018)(alsa -dbus -debug 
     Homepage:            http://qjackctl.sourceforge.net/
     Description:         Qt GUI to control the JACK Audio Connection Kit and 
ALSA sequencer connections

I tried enableing dbus but a successfull recompilation the problem is
still the same.

Any idea, what's going on here...it feels like starting firefox
switches of my TV.... 

Thank you very much in advance for any help!

Reply via email to