On 03/13/2018 12:11 PM, Neil Bothwick wrote:
> On Tue, 13 Mar 2018 11:36:12 -0600, the...@sys-concept.com wrote:
>> (sys-apps/portage-2.3.16:0/0::gentoo, ebuild scheduled for merge)
>> pulled in by sys-apps/portage (Argument)
>> (sys-apps/portage-2.3.6:0/0::gentoo, installed) pulled in by
>> required by (app-portage/gentoolkit-0.3.3:0/0::gentoo, installed)
> Your old version of gentoolkit (and other packages mentioned in the full
> output) is causing this. Trying to upgrade an out of date system
> piecemeal can cause this. Just do an emerge -u @system and let portage
> resolve these issues rather than trying to do it yourself.
I spoke too soon. Now, when I try: emerge -u @system
I'm getting an error as well.
emerge -ua @system
These are the packages that would be merged, in order:
Calculating dependencies... done!
WARNING: One or more updates/rebuilds have been skipped due to a dependency
(sys-libs/zlib-1.2.11-r1:0/1::gentoo, ebuild scheduled for merge) conflicts
>=sys-libs/zlib-1.2.8-r1:0/0=[abi_x86_32(-),abi_x86_64(-)] required by
(sys-libs/readline-7.0_p3:0/7::gentoo, ebuild scheduled for merge) conflicts
sys-libs/readline:0/0= required by (dev-lang/ruby-2.1.9:2.1/2.1::gentoo,
!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking: