It would be easier to see what is going on if you post some code that
reproduces the problem.


On Tue, Jul 23, 2019 at 3:35 AM <rites...@intech-dmls.in> wrote:

> Hi,
>
> We are created polygon and line. After performing the intersection
> function we are getting different values.
>
> This is the sample code we have implemented using GEOS API (GEOS 3.7.2) .
>
>        Rect = c1.createPolygon(10.78, 10.34, 18.89, 16.64);
>
>
>
>       line = c1.makeLine(10.78 , 12.34 ,18.89 , 12.34);
>
>
>
>       point = Rect->intersection (line)
>
>
>
> 1. If given line lies on the polygon we are getting the Expected result.
>
>
>
> *Input*: Polygon(10.78, 10.34, 18.89, 16.64);
>
> *Input:  *makeLine (10.78 , 12.34 ,18.89 , 12.34)
>
> *Current  Output from **intersection API :*  (10.78 , 12.34) (18.89 ,
> 12.34)
>
> *Expected Output :  *(10.78 , 12.34) (18.89 , 12.34)
>
>
>
> 2.  If given line lies away the polygon we are getting the different
> result.
>
> *Input:*  makeLine (8.78 , 12.34 ,20.89 , 12.34)
>
> *Current  Output from **intersection API:*    (11 , 12.3.4) (19 , 12.34)
>
> *Expected Output :  *(10.78 , 12.34) (18.89 , 12.34)
>
>
>
> Can you please suggest why this behaviour diffrence is there in API output.
>
> Please let me know any additional information needed from my side.
>
>
>
> Thanks,
>
> Ritesh
> _______________________________________________
> geos-devel mailing list
> geos-devel@lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/geos-devel
_______________________________________________
geos-devel mailing list
geos-devel@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/geos-devel

Reply via email to