Hi,

I'm trying to compile it on windows (7) in visual studio, but I keep
getting errors about attempting to reference a deleted function (C2280).

After quite some digging I found out that the usage of
std::vector<std::unique_ptr<SomeType>> was the cause of that. (Commenting
out that declaration and all its references got me a successful compile).

Tried it in vs2017 and vs2019, same results...
Both attempts done via the cmake support that has been built in in visual
studio (just open the folder containing the cmakelists.txt).

Strange thing is that in your ci builds just fine with vs2019, 2017 and
even 2015.
Checking the logs, the only difference I see is that in the ci, and
enterprise version is used, while I have the community edition. Find it
hard to believe that those 2 have different compilers...

Also tried running cmake (latest version), but that kept on complaining
that it couldn't find it's root and couldn't find CMakeDependentOption.

Has anyone experience with building in visual studio, or any pointers on
how to get this to work?
Will be greatly appreciated.

Paul
_______________________________________________
geos-devel mailing list
geos-devel@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/geos-devel

Reply via email to