Hi all
I'm using Geoserver 2.9, and I'm wondering about how Geoserver caches the
image mosaic images.

My set up
1. in the Database, I use the field 'dataset_id' to uniquely identify the
image, and the path to the image is also stored. 
2. I try to view the image like this
mosaic layer

My observation
1. First, I added an image. Everything was good, I could view it with no
2. Next, I updated the image path in the Database to point to a different
image, for the same dataset_id.
3. Then I tried to view the image, but I still got the old image, not the
new one.

I have tried
- Turning off Geowebcache
- Turning off Tile Caching for the Image Mosaic layer
- Ensuring all the 'caching' properties are set to false in the Image Mosaic
config files (datastore.properties, indexer.properties, <database
- Clearing my browser cache (as I was viewing the image via OpenLayers on a
web browser)

Restarting Geoserver does work, but we do not want to restart Geoserver.

Any ideas/comments are welcome.


View this message in context: 
Sent from the GeoServer - User mailing list archive at Nabble.com.

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Geoserver-users mailing list

Reply via email to