Thanks for the code example Andrea; I withdraw my earlier suggestion of
combining capabilities and info.
Because it is a capabilities document the "supports" is already assumed; so I
don't think we need to step outside of java beans naming conventions.
DataCapabilities capabilities = ds.getCapabilities();
if(!capabilities.isCreateSchema()) {
...
}
I do see the naming trouble in both cases; capabilities
On 27/04/2010, at 3:34 AM, Andrea Aime wrote:
> Hi PMC,
> since this is "proposal day" let me provide you with another one
> that sums up part of the discussion of the last week about a
> capabilities API in GeoTools:
>
> http://docs.codehaus.org/display/GEOTOOLS/Datastore+capabilities+API
>
> Opinions and votes welcomed
>
> Cheers
> Andrea
>
> --
> Andrea Aime
> OpenGeo - http://opengeo.org
> Expert service straight from the developers.
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Geotools-devel mailing list
> [email protected]
> https://lists.sourceforge.net/lists/listinfo/geotools-devel
------------------------------------------------------------------------------
_______________________________________________
Geotools-devel mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/geotools-devel