Patch Set 1: Code-Review-1

(6 comments)

https://gerrit.osmocom.org/#/c/2589/1/openbsc/src/libmsc/smpp_openbsc.c
File openbsc/src/libmsc/smpp_openbsc.c:

Line 464: #define SMPP_TO_GSM411_MAX 4
> You're defining this value but not using it the array definition... (s.b.)
Right. Keith, if you use ARRAY_SIZE() then we can skip this macro definition.


Line 466: struct x {
> (no x here please)
Keith, just remove this x. Keep it:

struct {
      ...


Line 477:       .smpp_status_code = ESME_RSYSERR,
> could omit the explicit names, just { ESME_X, GSM411_X }, ...
This is C99 structure initialization... which is actually a good idea since it 
makes code more readable and maintainable. Please keep it there.


PS1, Line 481: .
Add indent here, and everywhere inside the curly braces.


Line 502:       }
> (wrong indent)
That's equivalent... Fair enough.


Line 574:                            gsm411_cause);
This fits into the line, so no need to break it.


-- 
To view, visit https://gerrit.osmocom.org/2589
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I61fb2d9ef4f2d2eabdc49b53d9966ad328d15e51
Gerrit-PatchSet: 1
Gerrit-Project: openbsc
Gerrit-Branch: master
Gerrit-Owner: Keith Whyte <ke...@rhizomatica.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Neels Hofmeyr <nhofm...@sysmocom.de>
Gerrit-Reviewer: Pablo Neira Ayuso <pa...@gnumonks.org>
Gerrit-HasComments: Yes

Reply via email to