arehbein has posted comments on this change. ( 
https://gerrit.osmocom.org/c/osmo-upf/+/30466 )

Change subject: fix tunmap: mixup of Access/Core side FAR rules
......................................................................


Patch Set 1:

(1 comment)

Patchset:

PS1:
I find the commit message + ASCII graphic confusing. How do PDR-1, PDR-2 relate 
to PDR and 'reverse PDR'?
Similar for FAR-1, FAR-2.
I would have preferred something like (my understanding of the setup...):

      <--------|{{FAR}      PDR}|<-------
Access         |      UPF       |        Core
      -------->|{R-PDR  {R-FAR}}|------->

If that is correct and the field `tunmap.access` contains information on how to 
forward packets incoming on the access interface to the tunnel set up at the 
core interfaces and vice versa, then the fix makes sense to me.

I would be in favor of refactoring the identifiers/naming scheme concerning 
this, i.e. call the pairings 'pdr_at_core'/'far_at_core'
'pdr_at_access'/'far_at_access', or just 'pdr_core', 'pdr_access'... something 
among those lines



--
To view, visit https://gerrit.osmocom.org/c/osmo-upf/+/30466
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-upf
Gerrit-Branch: master
Gerrit-Change-Id: I66babdfe4c1746bd3bf259342ce80dae2661de8c
Gerrit-Change-Number: 30466
Gerrit-PatchSet: 1
Gerrit-Owner: neels <[email protected]>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: arehbein <[email protected]>
Gerrit-Reviewer: laforge <[email protected]>
Gerrit-Reviewer: neels <[email protected]>
Gerrit-Reviewer: pespin <[email protected]>
Gerrit-Comment-Date: Wed, 07 Dec 2022 22:17:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment

Reply via email to