dexter has submitted this change. ( 
https://gerrit.osmocom.org/c/osmo-bts/+/34584?usp=email )

Change subject: pcuif_proto: rename PCU_IF_FLAG_SYSMO to PCU_IF_FLAG_DIRECT_PHY
......................................................................

pcuif_proto: rename PCU_IF_FLAG_SYSMO to PCU_IF_FLAG_DIRECT_PHY

The PCUIF flag PCU_IF_FLAG_SYSMO was originally used by osmo-bts-sysmo
to signal to the PCU that the direct PHY access for the sysmo-bts DSP
should be enabled. With time, support for other BTS models was added and
the flag became a synonym for "direct PHY access", so it makes sense to
rename it to "PCU_IF_FLAG_DIRECT_PHY"

Related: OS#6191
Depends: osmo-pcu.git I29b7b78a3a91d062b9ea3cd72623d30618cd3f0b
Change-Id: Ib556a93f7d7d7dbe1e96c4a0802bc802241b2b2d
---
M include/osmo-bts/pcuif_proto.h
M src/common/pcu_sock.c
2 files changed, 19 insertions(+), 2 deletions(-)

Approvals:
  Jenkins Builder: Verified
  pespin: Looks good to me, but someone else must approve
  fixeria: Looks good to me, approved




diff --git a/include/osmo-bts/pcuif_proto.h b/include/osmo-bts/pcuif_proto.h
index b47dc75..a620993 100644
--- a/include/osmo-bts/pcuif_proto.h
+++ b/include/osmo-bts/pcuif_proto.h
@@ -40,7 +40,7 @@

 /* flags */
 #define PCU_IF_FLAG_ACTIVE     (1 << 0)/* BTS is active */
-#define PCU_IF_FLAG_SYSMO      (1 << 1)/* access PDCH of sysmoBTS directly */
+#define PCU_IF_FLAG_DIRECT_PHY (1 << 1)/* access PHY directly via dedicated 
hardware support */
 #define PCU_IF_FLAG_CS1                (1 << 16)
 #define PCU_IF_FLAG_CS2                (1 << 17)
 #define PCU_IF_FLAG_CS3                (1 << 18)
diff --git a/src/common/pcu_sock.c b/src/common/pcu_sock.c
index f99c7d2..79b39c4 100644
--- a/src/common/pcu_sock.c
+++ b/src/common/pcu_sock.c
@@ -264,7 +264,7 @@
                LOGP(DPCU, LOGL_INFO, "BTS is down\n");

        if (pcu_direct)
-               info_ind->flags |= PCU_IF_FLAG_SYSMO;
+               info_ind->flags |= PCU_IF_FLAG_DIRECT_PHY;

        info_ind->bsic = bts->bsic;
        /* RAI */

--
To view, visit https://gerrit.osmocom.org/c/osmo-bts/+/34584?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-bts
Gerrit-Branch: master
Gerrit-Change-Id: Ib556a93f7d7d7dbe1e96c4a0802bc802241b2b2d
Gerrit-Change-Number: 34584
Gerrit-PatchSet: 2
Gerrit-Owner: dexter <pma...@sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: dexter <pma...@sysmocom.de>
Gerrit-Reviewer: fixeria <vyanits...@sysmocom.de>
Gerrit-Reviewer: pespin <pes...@sysmocom.de>
Gerrit-MessageType: merged

Reply via email to