laforge has submitted this change. ( 
https://gerrit.osmocom.org/c/osmo-pcu/+/35224?usp=email )

Change subject: bts: rename struct member gen_idle_blocks to gen_idle_blocks_C0
......................................................................

bts: rename struct member gen_idle_blocks to gen_idle_blocks_C0

The struct member gen_idle_blocks controls whether the the PCU has to
generate dummy blocks to fill idle periods or if this task is left to
the BTS hardware.

Since idle dummy blocks only have to be transmitted on the C0 carrier,
we should rename the gen_idle_blocks struct member to
gen_idle_blocks_C0.

Related: OS#6198
Change-Id: If9511ed911f9c5d6d463881a387a9e7d11a15465
---
M src/bts.h
M src/gprs_rlcmac_sched.cpp
M src/pcu_l1_if.cpp
3 files changed, 22 insertions(+), 4 deletions(-)

Approvals:
  osmith: Looks good to me, but someone else must approve
  pespin: Looks good to me, but someone else must approve
  laforge: Looks good to me, approved
  Jenkins Builder: Verified




diff --git a/src/bts.h b/src/bts.h
index 86c161b..380c47c 100644
--- a/src/bts.h
+++ b/src/bts.h
@@ -282,7 +282,7 @@
        /* When the PDCH is idle, the timeslot is expected to transmit dummy 
blocks. Some BTS models will generate
         * those dummy blocks automatically when no data is transmitted. In 
contrast, other BTS models may require a
         * continuous stream of PDCH blocks that already has the gaps filled 
with dummy blocks. */
-       bool gen_idle_blocks;
+       bool gen_idle_blocks_C0;
 };

 struct paging_req_cs {
diff --git a/src/gprs_rlcmac_sched.cpp b/src/gprs_rlcmac_sched.cpp
index 12b9e50..ac58121 100644
--- a/src/gprs_rlcmac_sched.cpp
+++ b/src/gprs_rlcmac_sched.cpp
@@ -488,7 +488,7 @@
                                        + pdch->num_tbfs(GPRS_RLCMAC_UL_TBF);
                bool skip_idle = (num_tbfs == 0);

-               if (bts->gen_idle_blocks)
+               if (bts->gen_idle_blocks_C0)
                        skip_idle = skip_idle && trx != 0;

                if (!skip_idle && (msg = sched_dummy())) {
diff --git a/src/pcu_l1_if.cpp b/src/pcu_l1_if.cpp
index 07082d3..fb44bd8 100644
--- a/src/pcu_l1_if.cpp
+++ b/src/pcu_l1_if.cpp
@@ -552,7 +552,7 @@
                                + pdch->num_tbfs(GPRS_RLCMAC_UL_TBF);
        bool skip_idle = (num_tbfs == 0);

-       if (bts->gen_idle_blocks)
+       if (bts->gen_idle_blocks_C0)
                skip_idle = skip_idle && trx != 0;

        if (skip_idle) {
@@ -966,7 +966,7 @@

        LOGP(DL1IF, LOGL_INFO, "BTS model: %s\n", 
get_value_string(gsm_pcuif_bts_model_names, info_ind->bts_model));
        bts->bts_model = info_ind->bts_model;
-       bts->gen_idle_blocks = decide_gen_idle_blocks(bts);
+       bts->gen_idle_blocks_C0 = decide_gen_idle_blocks(bts);

        bts->active = true;
        return rc;

--
To view, visit https://gerrit.osmocom.org/c/osmo-pcu/+/35224?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-pcu
Gerrit-Branch: master
Gerrit-Change-Id: If9511ed911f9c5d6d463881a387a9e7d11a15465
Gerrit-Change-Number: 35224
Gerrit-PatchSet: 1
Gerrit-Owner: dexter <pma...@sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <vyanits...@sysmocom.de>
Gerrit-Reviewer: laforge <lafo...@osmocom.org>
Gerrit-Reviewer: osmith <osm...@sysmocom.de>
Gerrit-Reviewer: pespin <pes...@sysmocom.de>
Gerrit-MessageType: merged

Reply via email to