Review at  https://gerrit.osmocom.org/6339

Revert "Use python 3 for utilities"

This reverts commit 76c6c50405c6cbb1d08bdd7b5d27c657fa5d38b6, which broke the 
obs builds. I'm really starting to get annoyed by ongoing python related 
breakage without ever fixing any bugs!

Change-Id: I4d76e897d4f746ff9ea4e06f2efc708a12cc2944
---
M debian/control
M utils/conv_codes_gsm.py
M utils/conv_gen.py
3 files changed, 3 insertions(+), 3 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/libosmocore refs/changes/39/6339/1

diff --git a/debian/control b/debian/control
index 2a6fd4a..64c4870 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@
                libpcsclite-dev,
                pkg-config,
                libtalloc-dev,
-               python3
+               python (>= 2.7.6)
 Standards-Version: 3.9.8
 Vcs-Git: git://git.osmocom.org/libosmocore.git
 Vcs-Browser: http://git.osmocom.org/gitweb?p=libosmocore.git;a=summary
diff --git a/utils/conv_codes_gsm.py b/utils/conv_codes_gsm.py
index 72681e7..eeed4fd 100644
--- a/utils/conv_codes_gsm.py
+++ b/utils/conv_codes_gsm.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3
+#!/usr/bin/python2
 # -*- coding: utf-8 -*-
 from conv_gen import ConvolutionalCode
 from conv_gen import poly
diff --git a/utils/conv_gen.py b/utils/conv_gen.py
index d2eda15..6b6b267 100644
--- a/utils/conv_gen.py
+++ b/utils/conv_gen.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python3
+#!/usr/bin/python2
 
 mod_license = """
 /*

-- 
To view, visit https://gerrit.osmocom.org/6339
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I4d76e897d4f746ff9ea4e06f2efc708a12cc2944
Gerrit-PatchSet: 1
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Harald Welte <lafo...@gnumonks.org>

Reply via email to