Patch Set 1: I think we can introduce this. However, I'm not happy with the naming. First, "grace" is different from "grace period" or "graceful" (think of "holy grace", ...). Second, I think it's not very indicative/explanatory of what is actually happening. Withouht thinking too much about it, I think "pre_term" or even "term" might be a beter name. After all, it's called from "osmo_fsm_inst_term". So first we call the termination code, then we terminate children and finally we cleanup, just before the free.
-- To view, visit https://gerrit.osmocom.org/6452 To unsubscribe, visit https://gerrit.osmocom.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I0fdda9fe994753f975a658c0f3fb3615949cc8bb Gerrit-PatchSet: 1 Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-Owner: dexter <pma...@sysmocom.de> Gerrit-Reviewer: Harald Welte <lafo...@gnumonks.org> Gerrit-Reviewer: Jenkins Builder Gerrit-HasComments: No