Attention is currently required from: laforge. dexter has posted comments on this change by dexter. ( https://gerrit.osmocom.org/c/pysim/+/42734?usp=email )
Change subject: card_key_provider: move boiler-plate code into helper functions ...................................................................... Patch Set 2: (2 comments) File pySim/card_key_provider.py: https://gerrit.osmocom.org/c/pysim/+/42734/comment/e3184fda_128a1aca?usp=email : PS1, Line 337: def argparse_add_card_key_provider_args(arg_parser: argparse.ArgumentParser): > to be consistent with other methods I would call it > card_key_provider_argparse_add_args or something […] I took the scheme from pySim/transport/__init__.py. There we use the prefixes argparse_add_ and init_. But I see, there is already card_key_provider_register. Now everything falls apart. I would say the consistency inside the file weighs more then the consistency throughout modules. https://gerrit.osmocom.org/c/pysim/+/42734/comment/e6b32bfa_0b3b1024?usp=email : PS1, Line 344: init_card_key_provider > likewise here I'd call it card_key_provider_init similar to > card_key_provider_{get,get_field} above Yes, let's use the card_key_provider_ prefix. -- To view, visit https://gerrit.osmocom.org/c/pysim/+/42734?usp=email To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: pysim Gerrit-Branch: master Gerrit-Change-Id: I6d095cbb644e608f4a751a1d0749b1484cdc781d Gerrit-Change-Number: 42734 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <[email protected]> Gerrit-Reviewer: Jenkins Builder Gerrit-CC: laforge <[email protected]> Gerrit-Attention: laforge <[email protected]> Gerrit-Comment-Date: Fri, 08 May 2026 15:55:31 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: laforge <[email protected]>
