jenkins: use env POKY_VERSION POKY_PATH to find poky

Instead of hardcoded values, use defaults and allow jenkins to override
the defaults.

Change-Id: I1403b32cdf30420f3b02c41c2627b71fcbeae9ab
---
M contrib/jenkins-build-osmo-bts-sysmo.sh
M contrib/jenkins-build-osmo-pcu-sysmo.sh
2 files changed, 16 insertions(+), 6 deletions(-)


  git pull ssh://gerrit.osmocom.org:29418/osmo-gsm-tester refs/changes/24/7124/2

diff --git a/contrib/jenkins-build-osmo-bts-sysmo.sh 
b/contrib/jenkins-build-osmo-bts-sysmo.sh
index 59ba85d..1a8876d 100755
--- a/contrib/jenkins-build-osmo-bts-sysmo.sh
+++ b/contrib/jenkins-build-osmo-bts-sysmo.sh
@@ -1,11 +1,16 @@
 #!/bin/sh
 set -e -x
 
-poky="/opt/poky/1.5.4"
-. "$poky/environment-setup-armv5te-poky-linux-gnueabi"
+_poky_version="$POKY_VERSION"
+_poky_path="$POKY_PATH"
+
+[ -z "$_poky_version" ] && _poky_version="1.5.4"
+[ -z "$_poky_path" ] && _poky_path="/opt/poky/$_poky_version"
+
+. "$_poky_path/environment-setup-armv5te-poky-linux-gnueabi"
 
 # Cross-compilation: all installations need to be put in the sysmo SDK sysroot
-export DESTDIR="$poky/sysroots/armv5te-poky-linux-gnueabi"
+export DESTDIR="$_poky_path/sysroots/armv5te-poky-linux-gnueabi"
 
 base="$PWD"
 name="osmo-bts-sysmo"
diff --git a/contrib/jenkins-build-osmo-pcu-sysmo.sh 
b/contrib/jenkins-build-osmo-pcu-sysmo.sh
index 7cd1142..2ed3426 100755
--- a/contrib/jenkins-build-osmo-pcu-sysmo.sh
+++ b/contrib/jenkins-build-osmo-pcu-sysmo.sh
@@ -1,11 +1,16 @@
 #!/bin/sh
 set -e -x
 
-poky="/opt/poky/1.5.4"
-. "$poky/environment-setup-armv5te-poky-linux-gnueabi"
+_poky_version="$POKY_VERSION"
+_poky_path="$POKY_PATH"
+
+[ -z "$_poky_version" ] && _poky_version="1.5.4"
+[ -z "$_poky_path" ] && _poky_path="/opt/poky/$_poky_version"
+
+. "$_poky_path/environment-setup-armv5te-poky-linux-gnueabi"
 
 # Cross-compilation: all installations need to be put in the sysmo SDK sysroot
-export DESTDIR="$poky/sysroots/armv5te-poky-linux-gnueabi"
+export DESTDIR="$_poky_path/sysroots/armv5te-poky-linux-gnueabi"
 
 base="$PWD"
 name="osmo-pcu-sysmo"

-- 
To view, visit https://gerrit.osmocom.org/7124
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I1403b32cdf30420f3b02c41c2627b71fcbeae9ab
Gerrit-PatchSet: 2
Gerrit-Project: osmo-gsm-tester
Gerrit-Branch: master
Gerrit-Owner: lynxis lazus <lyn...@fe80.eu>
Gerrit-Reviewer: Pau Espin Pedrol <pes...@sysmocom.de>

Reply via email to