Visit 
https://build.opensuse.org/package/live_build_log/network:osmocom:latest/osmo-trx/Debian_Unstable/x86_64

Package network:osmocom:latest/osmo-trx failed to build in 
Debian_Unstable/x86_64

Check out the package for editing:
  osc checkout network:osmocom:latest osmo-trx

Last lines of build log:
[  490s] ar: `u' modifier ignored since `D' is the default (see `U')
[  490s] libtool: link: ranlib .libs/libtransceiver_common.a
[  490s] libtool: link: ( cd ".libs" && rm -f "libtransceiver_common.la" && ln 
-s "../libtransceiver_common.la" "libtransceiver_common.la" )
[  490s] /bin/bash ../libtool  --tag=CXX   --mode=link g++ -lpthread 
-I/usr/include/ -I/usr/include/ -I/usr/include/ -g -O2 
-fdebug-prefix-map=/usr/src/packages/BUILD=. -fstack-protector-strong -Wformat 
-Werror=format-security  -Wl,-z,relro -Wl,-z,now -o osmo-trx-uhd 
osmo_trx_uhd-osmo-trx.o ./device/uhd/libdevice.la libtransceiver_common.la 
../Transceiver52M/arch/x86/libarch.la ../GSM/libGSM.la 
../CommonLibs/libcommon.la -lfftw3f -ltalloc -losmocore -ltalloc -losmoctrl 
-losmogsm -losmocore -ltalloc -losmovty -losmocore -luhd 
[  491s] libtool: link: g++ -I/usr/include/ -I/usr/include/ -I/usr/include/ -g 
-O2 -fdebug-prefix-map=/usr/src/packages/BUILD=. -fstack-protector-strong 
-Wformat -Werror=format-security -Wl,-z -Wl,relro -Wl,-z -Wl,now -o 
osmo-trx-uhd osmo_trx_uhd-osmo-trx.o  ./device/uhd/.libs/libdevice.a 
./.libs/libtransceiver_common.a ../Transceiver52M/arch/x86/.libs/libarch.a 
../GSM/.libs/libGSM.a ../CommonLibs/.libs/libcommon.a -lpthread -lfftw3f 
/usr/lib/x86_64-linux-gnu/libosmoctrl.so 
/usr/lib/x86_64-linux-gnu/libosmogsm.so -ltalloc 
/usr/lib/x86_64-linux-gnu/libosmovty.so 
/usr/lib/x86_64-linux-gnu/libosmocore.so -luhd
[  491s] /usr/bin/ld: ./device/uhd/.libs/libdevice.a(UHDDevice.o): undefined 
reference to symbol '_ZN5boost6system16generic_categoryEv'
[  491s] /usr/bin/ld: /usr/lib/x86_64-linux-gnu/libboost_system.so.1.67.0: 
error adding symbols: DSO missing from command line
[  491s] collect2: error: ld returned 1 exit status
[  491s] make[4]: *** [Makefile:681: osmo-trx-uhd] Error 1
[  491s] make[4]: Leaving directory '/usr/src/packages/BUILD/Transceiver52M'
[  491s] make[3]: *** [Makefile:820: all-recursive] Error 1
[  491s] make[3]: Leaving directory '/usr/src/packages/BUILD/Transceiver52M'
[  491s] make[2]: *** [Makefile:513: all-recursive] Error 1
[  491s] make[2]: Leaving directory '/usr/src/packages/BUILD'
[  491s] make[1]: *** [Makefile:444: all] Error 2
[  491s] make[1]: Leaving directory '/usr/src/packages/BUILD'
[  491s] dh_auto_build: make -j1 returned exit code 2
[  491s] make: *** [debian/rules:6: build] Error 255
[  491s] dpkg-buildpackage: error: debian/rules build subprocess returned exit 
status 2
[  491s] 
[  491s] lamb56 failed "build osmo-trx_1.1.1.dsc" at Fri Aug 16 04:52:06 UTC 
2019.
[  491s] 
[  491s] ### VM INTERACTION START ###
[  494s] [  475.018740] sysrq: SysRq : Power Off
[  494s] [  475.025302] reboot: Power down
[  494s] ### VM INTERACTION END ###
[  494s] 
[  494s] lamb56 failed "build osmo-trx_1.1.1.dsc" at Fri Aug 16 04:52:10 UTC 
2019.
[  494s] 

-- 
Configure notifications at https://build.opensuse.org/user/notifications
openSUSE Build Service (https://build.opensuse.org/)

Reply via email to