It's likely that you're missing LD_LIBRARY_PATH when you're loading GIMP.
While you're starting GIMP that was compiled from Git it is loading GEGL
libraries from other sources.  You should do the following (assuming GIMP,
GEGL, and BABL were installed under /usr/local prefix by default):

LD_LIBRARY_PATH=/usr/local/lib gimp-2.9

GIMP will then look to /usr/local/lib for its GEGL and BABL libraries
instead of /usr/lib (which is where it is typically installed by a package
manager).

On Wed, Oct 7, 2015 at 11:31 PM, Olivier <oleca...@gmail.com> wrote:

> In fact, I also built glib from git, thus maybe GIO_EXTRA_MODULES was also
> needed. Anyway, I used it and everything is OK now.
>
> Olivier Lecarme
>
> 2015-10-07 21:23 GMT+02:00 Elle Stone <ellest...@ninedegreesbelow.com>:
>
> > On 10/07/2015 12:54 PM, Olivier wrote:
> >
> >> ​Finally I succedded in installing ​GIMP,  by fetching gegl, babl,
> >> gdk-pixbuf, and gimp itself from git, and configuring and installing
> >> them all under the same prefix. Under Ubuntu 15.04, the GIO extra
> >> modules are located in usr/lib/x86_64-linux-gnu/gio/modules.
> >>
> >> Thus I used Martin Nordholts' explanation in
> >> http://www.gimp.org/source/howtos/gimp-git-build.html, but I added
> gegl,
> >> babl, and gdk-pixbuf tothe packages to be fetched from git, compiled and
> >> installed, and I added GIO_EXTRA_MODULES  to the exported variables,
> >> although I'm not sure that is needed.
> >>
> >> Thanks to all!
> >>
> >> Olivier Lecarme
> >>
> >
> > Based on comments in https://aur.archlinux.org/packages/gegl-git/, it
> > does look like maybe the original problem was that GIMP was finding a
> > too-outdated version of GEGL.
> >
> > I never needed to export GIO_EXTRA_MODULES until I tried to run GIMP 2.8
> > installed from the Gentoo package manager alongside babl/GEGL/GIMP from
> git
> > installed in a prefix. But here's the reference, fwiw:
> >
> >
> >
> https://mail.gnome.org/archives/gimp-developer-list/2015-February/msg00042.html
> >
> >
> https://mail.gnome.org/archives/gimp-developer-list/2015-February/msg00051.html
> >
> > Looking at what Mitch said, it seems exporting GIO_EXTRA_MODULES is only
> > be needed if glib is also built in the prefix. So sorry for the noise! if
> > you didn't also build glib in the prefix.
> >
> > For the next person trying to build GIMP from git who might stumble over
> > this thread, a few other "why it doesn't work and what to do" are
> > documented here:
> >
> > http://wiki.gimp.org/wiki/Hacking:Problems_and_solutions
> >
> >
>
>
> --
> Olivier Lecarme
> _______________________________________________
> gimp-developer-list mailing list
> List address:    gimp-developer-list@gnome.org
> List membership:
> https://mail.gnome.org/mailman/listinfo/gimp-developer-list
> List archives:   https://mail.gnome.org/archives/gimp-developer-list
>



-- 
I prefer to encrypt my email

GPG FINGERPRINT 4096 KEY
8D8B F0E2 42D8 A068 572E
BF3C E8F7 3234 7257 E65F
https://keybase.io/samrocketman

Learn how to encrypt your email with the Email Self Defense guide:
https://emailselfdefense.fsf.org/en/
_______________________________________________
gimp-developer-list mailing list
List address:    gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list

Reply via email to