On 11/18/2015 06:22 AM, Jon Nordby wrote:
We do this in imgflo, which is based on GEGL. There is no GTK+ though, and
would need to build more dependencies to be fully distro-independent*.

Gentoo allows to run a command ("emerge -epv gimp") that shows *all* the dependencies for a package as installed, all the way down to the toolchain for building.

It turns out that 268 packages are required to install GIMP 2.8.14 on my rather minimal Gentoo installation, and no additional packages are required to install babl/GEGL/GIMP from git in a prefix.

In case it might be helpful, I put up a spreadsheet listing the 268 packages: http://ninedegreesbelow.com/files/spreadsheets/gimp-dependencies.ods
gimp-developer-list mailing list
List address:    gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list

Reply via email to