Hi,

I am currently fixing this "grab_stuff.sh" script -
http://wiki.gimp.org/wiki/Hacking:Building/Windows#Cross-Compiling_GIMP_under_UNIX_using_MinGW-w64

It needed line 9 adjusting to REPO="openSUSE_42.1" and now it downloads
stuff. It can't find some packages which is easily fixed by using
https://software.opensuse.org/search ... but somewhat perplexing is the
inclusion of mingw32 packages seemingly due to what is from line 235 of
"download-mingw-rpm.py" ...

  if options.makezip or options.metadata:
    package = _findPackage(args[0]) #if args[0].endswith('.rpm')
    if package == None: package = _findPackage("mingw32-"+args[0],
options.srcpkg)
    if package == None: package = _findPackage("mingw64-"+args[0],
options.srcpkg)
    [...]

Thinking of forcing only w64 packages which seem to be available, but is
there some reason that the build has to happen with some mingw32 packages ?

Cheers

Barney Holmes
_______________________________________________
gimp-developer-list mailing list
List address:    gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list

Reply via email to