I solved the problem. I set $PERL5LIB and configured my path so perl5
actually pointed to the newest version of perl instead of 5.004. Whoops.

Thanks anyway,
Kevin

p.s. Gimp and script-fu work great on our SGI Origin200!

On Tue, 15 May 2001, Kevin Beason wrote:
]
]       When running gimp.1.2.1/configure, I get these errors:
]
] ============================== 8< ===================================
]
] ...
] invoking perl for configuration...
]
] WARNING: unable to use PDL (the perl data language). This means that
]          normal pixel access is non-functional. Unless you plan to use
]          Tile/PixelRgn functions together with PDL, this is harmless. The
]          plug-ins using PDL, however, will NOT WORK and you can NO LONGER
]          install PDL later. You can get PDL from any CPAN mirror.
]
] checking for PDL support... no
]
] NOTICE:  You are using a version of perl older than 5.005. This will
] slightly
]          reduce the features available to the Gimp-Perl extension.
]
]
] NOTICE:  unable to use the Perl-Gtk interface. Many features (like
]          Gimp::Fu) rely on this extension. You can build without it (and
]          many scripts will be disabled or run with reduced functionality
]          only), but it's better to install it (version 0.6123 or higher is
]          required, you can get it from ftp://ftp.gimp.org/pub/gtk/perl/ or
]          any CPAN mirror.
]
] ============================== 8< ===================================
]
]       I get these errors when the perl it invokes tries to execute "use
] PDL" and "use Gtk". Those commands result in errors because PDL and Gtk
] are installed in my homedir,
] /home/mydir/lib/perl5/site_perl/5.6.0/IP27-irix which is not in @INC by
] default.
]
]       However, PDL and Gtk ARE installed, because if I do:
]
] echo 'use PDL; use Gtk'|perl -I/home/mydir/lib/perl5/site_perl/5.6.0/IP27-irix
]
]       Then perl exits without any error. Alternatively, if I try to just do:
]
] echo 'use PDL; use Gtk'|perl
]
]       then I get this error:
]
] ================================ 8< =================================
]
] Can't locate PDL.pm in
] @INC (@INC contains: /lib/perl5/site_perl/5.6.0/IP27-irix
] /usr/local/lib/perl5/5.6.0/IP27-irix /usr/local/lib/perl5/5.6.0
] /usr/local/lib/perl5/site_perl/5.6.0/IP27-irix
] /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl .) at
] - line 1.
] BEGIN failed--compilation aborted at - line 1.
]
] ================================ 8< =================================
]
]       Obviously I need some way to let gimp.1.2.1/configure know to tell
] perl to include the directory
] /home/mydir/lib/perl5/site_perl/5.6.0/IP27-irix.
]
]       I've tried using $PERL_MM_OPT, PREFIX=..., LIB=..., combinations
] thereof, etc. to no avail.
]
]       If you could carbon-copy any response to me at [EMAIL PROTECTED] I
] would greatly appreciate it. I have spent four days trying to get gimp to
] compile with all the gizmo's and this is holding me back.
]
] Thank you very much in advance!
] Kevin Beason
]
]

-- 
 .-=^-----------------------------////=---------------------------^=-.
 Kevin M. Beason    FSU computer science graduate    [EMAIL PROTECTED]
 (850)656-6898  http://www.cs.fsu.edu/~beason/  [EMAIL PROTECTED]
 ^=-.---------=///----------------------=////---------------------.-=^

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to