i get the following errors when i try to compile Gimp 1.2.2-pre1.

Not being a Gimp or perl guru, i've no idea what's going on;
hope you guys do.

i'm using

glibc     2.2.3
make      3.79.1
gcc       2.95.3
perl      5.6.1
Gtk-Perl  0.7007
PDL       2.2.1

error from make:
-----------------------------------------------------------------

usr/bin/perl -I/usr/lib/perl5/5.6.1/i586-linux-thread -I/usr/lib/perl5/5.6.1 
/usr/lib/perl5/5.6.1/ExtUtils/xsubpp  -typemap /usr/lib/perl5/5.6.1/ExtUtils/typemap 
-typemap /var/src/gimp-1.2.2-pre1/plug-ins/perl/typemap -typemap 
/usr/lib/perl5/site_perl/5.6.1/i586-linux-thread/PDL/Core/typemap.pdl Lib.xs > Lib.xsc 
&& mv Lib.xsc Lib.c
gcc -c -I/var/src/gimp-1.2.2-pre1/plug-ins/perl -I../../.. 
-I/var/src/gimp-1.2.2-pre1/plug-ins/perl/../.. -I/usr/include/glib-1.2 
-I/usr/lib/glib/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 
-I/usr/lib/glib/include -I/usr/X11R6/include  -DGTK_DISABLE_COMPAT_H 
-I/usr/lib/perl5/site_perl/5.6.1/i586-linux-thread/PDL/Core -O2 -mcpu=i686 
-fomit-frame-pointer  -pipe  -D_REENTRANT -fno-strict-aliasing -I/usr/local/include 
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -mcpu=i686 -O2 -pipe   -DVERSION=\"1.201\" 
-DXS_VERSION=\"1.201\" -fpic -I/usr/lib/perl5/5.6.1/i586-linux-thread/CORE 
-Ddatadir="\"/usr/local/share\"" -DHAVE_PDL=1  Lib.c
Lib.xs: In function `need_pdl':
Lib.xs:97: warning: passing arg 1 of `Perl_croak' from incompatible pointer type
Lib.xs:97: too few arguments to function `Perl_croak'
Lib.xs: In function `old_pdl':
Lib.xs:126: warning: passing arg 1 of `Perl_croak' from incompatible pointer type
Lib.xs:126: warning: passing arg 2 of `Perl_croak' makes pointer from integer without 
a cast

[...]

Lib.xs: In function `pii_run':
Lib.xs:1196: `thr' undeclared (first use in this function)
Lib.xs:1196: (Each undeclared identifier is reported only once
Lib.xs:1196: for each function it appears in.)

[...]

Lib.xs: In function `XS_Gimp__Lib_gimp_main':
Lib.xs:1345: warning: passing arg 1 of `Perl_croak' from incompatible pointer type
Lib.xs:1345: too few arguments to function `Perl_croak'

[...]

make[4]: *** [Lib.o] Error 1
make[4]: Leaving directory `/var/src/gimp-1.2.2-pre1/plug-ins/perl/Gimp'
make[3]: *** [subdirs] Error 2
make[3]: Leaving directory `/var/src/gimp-1.2.2-pre1/plug-ins/perl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/src/gimp-1.2.2-pre1/plug-ins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/src/gimp-1.2.2-pre1'
make: *** [all-recursive-am] Error 2

-------------------------------------------------------------------
b
<[EMAIL PROTECTED]>
_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to