I misgave my autoconf version.  Debian unstable uses some runtime 
autodetecting that looks at the extensions to configure scripts.  If gimp 
needs autoconf 2.50 it should be using configure.ac if i remember correctly, 
.in is depreciated and associated with 2.13.  Perhaps that's part of the 
reason why this error is occuring for me.    I do have the latest gnu 
building environment that debian unstable offers.  That is 2.52 .   

On Thursday 13 September 2001 03:36, safemode wrote:
> I'm not on the list so if you know what's wrong here dont forget to cc me.
> I'm using debian unstable and have compiled gimp many times before.  For
> the past few weeks, however, i've been getting this error.  pkg-config is
> found so it seems like there is a problem with automake.   i've rerun
> autogen.sh and i dont get any unusual errors.  I'll add that to the bottom
> of the mail. I'm using automake (GNU automake) 1.4-p4 and Autoconf version
> 2.13 .  Any other info needed?
> -- Errors from running configure
> configure.in:46: AC_PROG_CPP was called before AC_PROG_CC
> checking for pkg-config... /usr/bin/pkg-config
> ./configure: line 8536: syntax error near unexpected token
> `AM_PATH_GTK_2_0(1.3.7,,'
> ./configure: line 8536: `AM_PATH_GTK_2_0(1.3.7,,'
> Now type 'make' to compile GIMP.
> -- autogen.sh output warnings.
> Adding an entry to po/ChangeLog (backup is in po/ChangeLog~)
> Please add the files
>   codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
>   progtest.m4
> from the /usr/share/aclocal directory to your autoconf macro directory
> or directly to your aclocal.m4 file.
> You will also need config.guess and config.sub, which you can get from
> ftp://ftp.gnu.org/pub/gnu/config/.
Gimp-developer mailing list

Reply via email to