Ok, compiling gtk+ from the cvs and i'm getting this error. 
gdk-pixbuf.c:395: parse error before ')' token
gdk-pixbuf.c:396: parse error before ')' token
gdk-pixbuf.c:397: parse error before ')' token
make[3]: *** [gdk-pixbuf.lo] Error 1

it seems to be because the version variables aren't declared anywhere or set 
correctly.  Manually assigning the numbers 1 3 and 7 to them allowed the file 
to be compiled but because the version information isn't being set right, 
linking eventually failed with this

libtool: link: CURRENT `-' is not a nonnegative integer
libtool: link: `-::-' is not valid version information
make[3]: *** [libgdk_pixbuf-1.3.la] Error 1

this is the latest cvs.  is there a release of 2.0 i should be grabbing from 
the cvs instead of the very latest testing?  

On Thursday 13 September 2001 07:12, Sven Neumann wrote:
> Hi,
> safemode <[EMAIL PROTECTED]> writes:
> > I'm not on the list so if you know what's wrong here dont forget to cc
> > me. I'm using debian unstable and have compiled gimp many times before. 
> > For the past few weeks, however, i've been getting this error. 
> > pkg-config is found so it seems like there is a problem with automake.
> > -- Errors from running configure
> > configure.in:46: AC_PROG_CPP was called before AC_PROG_CC
> > checking for pkg-config... /usr/bin/pkg-config
> > ./configure: line 8536: syntax error near unexpected token
> > `AM_PATH_GTK_2_0(1.3.7,,'
> > ./configure: line 8536: `AM_PATH_GTK_2_0(1.3.7,,'
> you don't have the required version of GTK+ installed or if it is
> installed, aclocal is unable to find the gtk-2.0.m4 script. Make sure you
> have everything installed as described in INSTALL and set your
> ACLOCAL_FLAGS to "-I $prefix_where_gtk2_is_installed/share/aclocal" and
> rerun autogen.sh.
> Salut, Sven
Gimp-developer mailing list

Reply via email to