Hi!

        Thanks for your answer but it didn't work! I've tried:

[nach@myhost ~/gimp]$ telnet myhost 10008
Trying myip...
Connected to myhost.
Escape character is '^]'.
8(set! x)
Connection closed by foreign host.

[nach@myhost ~/gimp]$ telnet myhost 10008
Trying myip...
Connected to myhost.
Escape character is '^]'.
08(set! x)
Connection closed by foreign host.

        Can you help me with another sugestion? I'm running out of ideas...
:-( if not, I think I'm going to read the source!?

-- 
     o__                Bem haja,
    _.>/ _                      NunoACHenriques
   (_) \(_)                     ~~~~~~~~~~~~~~~
                                http://students.fct.unl.pt/users/nuno/

On Fri, 14 Sep 2001, Simon Budig wrote:

>NunoACHenriques ([EMAIL PROTECTED]) wrote:
>>      Where can I find documentation about the Script-fu-server protocol?
>>
>>      Sorry if this is an off-topic post but I couldn't find the Protocol
>> anywhere and my problem is:
>>
>>      I run the gimp-script-fu-server (Gimp 1.2.1 for Linux) and I have a C
>> program that opens a TCP socket to it (port 10008). I get connected but when
>> I send a simple command like "(set! x)" the server shutdown the socket?!...
>> :-( What am I doing wrong?
>
>Uh - does this still work? It has been a long time since i made some
>experiments with this...
>
>IIRC you basically have to encode the size of the request in (one? two?)
>bytes and prefix this to the command...
>
>However, you have to read the source to get some information on that...
>
>Bye,
>        Simon
>

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to