Hi,

Nick Hudson <[EMAIL PROTECTED]> writes:

> I keep getting this error when compiling the dev version of Gimp...
> 
> ar cru .libs/libgimpwidgets-1.3.a  gimpwidgetsmarshal.o gimpwidgets.o gimpbutton.o 
>gimpchainbutton.o gimpcolorarea.o gimpcolorbutton.o gimpdialog.o gimpfileselection.o 
>gimphelpui.o gimpoffsetarea.o gimppatheditor.o gimppixmap.o gimpquerybox.o 
>gimpsizeentry.o gimpstock.o gimpunitmenu.o 
> ranlib .libs/libgimpwidgets-1.3.a
> creating libgimpwidgets-1.3.la
> (cd .libs && rm -f libgimpwidgets-1.3.la && ln -s ../libgimpwidgets-1.3.la 
>libgimpwidgets-1.3.la)
> make[2]: Leaving directory `/usr/src/gimp-1.3.6/libgimpwidgets'
> Making all in libgimpproxy
> make[2]: Entering directory `/usr/src/gimp-1.3.6/libgimpproxy'
> make[2]: *** No rule to make target `../tools/gimp-mkproxy', needed by 
>`gimpobject.c'.  Stop.
> make[2]: Leaving directory `/usr/src/gimp-1.3.6/libgimpproxy'
>  ! Problem Detected ! 
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/gimp-1.3.6'
> make: *** [all-recursive-am] Error 2
> 
> 
> Any idea on why it would be doing this?

yes, Nathan forgot to add gimp-mkproxy to EXTRA_DIST and its missing from
the tarball for that reason. As I've already explained in 

  http://bugzilla.gnome.org/show_bug.cgi?id=83455

you shouldn't need gimp-mkproxy since the files it generates are
distributed. I wonder why the Makefile is trying to regenerate them
especially since I created the tarball using make distcheck which 
checks that all needed files are there. As a workaround, try to
touch the .c and .h files in libgimpproxy and rerun make.


Salut, Sven
_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to