Hi back,
On 2002-12-13 at 1741.32 +0100, Sven Neumann typed this:
> Hi,
> "Matthew Lewis" <[EMAIL PROTECTED]> writes:
> > After some research, I've discovered some things about fonts, gimp,
> > and linux. (Some of this may be old news to many of you, but it was
> > new to me because I'm not a font expert.) On RH8.0 (and probably
> > other dist's as well) there are 3 font handlers. The first is the
> > traditional X font server "xfs" or "xfstt" on some systems. The
> > other two font handlers are Xft and the new Xft2. Xfs gets it's
> > configuration from the familiar /etc/X11/XF86Config file and from
> > /etc/X11/fs/config. Nothing new here. The Xft font handler uses
> > /etc/X11/XftConfig for it's config (it may also be in
> > /usr/X11R6/lib/X11 as well). But the newest version of Xft called
> > Xft2 uses a pair of new config files which live in /etc/fonts called
> > "fonts.conf" and "fonts.dtd".
> RedHat ships with development versions of Pango so this is a
> RedHat-only situation. They may have had good reasons to do
> this. However this is totally unrelated to fonts in the GIMP text
> tool since the GIMP text tool doesn't use X11 to render fonts. It
> uses PangoFT2 which only happens to share a configuration file with
> PangoXft.
> > This situtation kinda sucks because I have a lot of nice looking
> > fonts which are useless under 1.3.10, but work perfectly under
> > 1.2.3. I'm not sure why the font hadlers have become so fragmented
> > under X/Gnome/Gimp, but it would be nice if there was some way to
> > regain the use of the font libraries which worked under earlier
> > versions of Gimp.
> I wouldn't say that the fonts worked perfectly under GIMP-1.2.3 since
> if anything sucks than it's the text tool in GIMP-1.2. The new tool
> however is under development and subject to changes. You better stop
> complaining. Then you should decide if you want to help with that
> development. Any help is appreciated. If all you want to do is to use
> The GIMP, you better delete GIMP-1.3.10 today and wait till we call it
> a stable version.
my gimp-1.2 gets ttf fonts via the development plug-in gimp-freetype.
the default text tool and the stable dynamic text plug-in are not able
to see the ttf fonts.

my gimp-1.3 text tool cannot find the ttf fonts.  i was sort of waiting
for a "Configure" button to pop up on one of my builds.

i was sort of excited about the original mail in this thread, as it was
the first thing i read that seemed to start to make sense of my font

i am running mostly debian testing, but i was willing (and would be
willing again) to run a broken half sid machine to get ttf to my stable

if you are curious about what i have done to fix my font problem, i
could dig up about 10 different how-tos.  from apt-get, from xfce, from
nice swedes trying to help ....

this is the first one that didn't work for me:

what are the chances that a [Configure] will appear on the text tool
dialog in the near future? 


Gimp-developer mailing list

Reply via email to