On Thu, Mar 20, 2003 at 05:28:45PM +0100, Sven Neumann wrote:
> 
> plug-ins/script-fu/interp_slib.c
> 
> I'd rather not have to rewrite this one. But then we have always very
> clearly stated the source of the SIOD interpreter that runs Script-Fu.
> Just go and try 'gimp-1.3 -i -b -'. You will see the following lines:
> 
>  Welcome to SIOD, Scheme In One Defun, Version 3.2x 12-MAR-96
>  (C) Copyright 1988-1994 Paradigm Associates Inc. Help: (help)
> 
> IMO this is exactly what the SIOD license asks for. I don't see any
> problems.

Non-compliance to the various licenses of some code chunks
is only one side of the problem. The other side is
compliance to GNU GPL.

OK, let's say we do what the other licenses ask for.

But most of code is GPL, and it doesn't allow combining with
code requiring advertisements, because this is a conflicting
additional restriction on further distribution and
modification.

A least this is how I understand it.

Yeti

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to