On Mon, Jun 07, 2004 at 12:28:07PM -0300, Rodrigo Severo wrote:
> Hi,
> 
> 
> I'm having problems compiling Gimp 2.0.1 on my Conectiva Linux 9 machine.
> 
> The error is:
> 
> if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../app 
> -I/usr/local/gtk+/include/gtk-2.0 -I/usr/local/glib/include/glib-2.0 
> -I/usr/local/glib/lib/glib-2.0/include 
> -I/usr/local/glib/include/glib-2.0 
> -I/usr/local/glib/lib/glib-2.0/include 
> -I/usr/local/pango/include/pango-1.0 -I/usr/X11R6/include 

^^ that's your problem. Your pango is built against the old fontconfig
in /usr/X11R6. Hence it gets pulled in. If you built pango against your
new fontconfig, you wouldn't have this problem.

I think the configure script can be amended to detect this. Sigh, GIMP's
configure.in: an encylopedia of how users and distro people can screw up
a system.

-Yosh
_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to