I've been trying to compile Gimp on Win32 to confirm that my TWAIN plugin patch for Mac OS X support won't break it on Windows. After much fiddling I've managed to get 2.1.2 to compile and even run, but automake craps out so I can't compile direct from CVS or get it to update configure.in and the various Makefile.in's:

$ ./autogen.sh --prefix=/c/Brion/obj/gimp --disable-print

I am testing that you have the required versions of libtool, autoconf,
automake, glib-gettextize and intltoolize. This test is not foolproof,
so if anything goes wrong, see the file HACKING for more information...

Looks like Win32, you will need libtool 1.5 or newer.

checking for libtool >= 1.5 ... yes (version 1.5)
checking for autoconf >= 2.54 ... yes (version 2.56)
checking for automake >= 1.6 ... yes (version 1.7.1)
checking for glib-gettextize >= 2.2.0 ... yes (version 2.4.2)
checking for intltool >= 0.17 ... yes (version 0.27.2)
checking for intltool < 0.28 or > 0.31 ... yes
checking for xsltproc ... yes
/tmp/am4t7.308/traces.m4:1397: /bin/m4: Error matching regular expression "^ *\(.*\) *$"
Use of uninitialized value in split at /bin/automake-1.7 line 5077, <GEN0> line 397.
automake-1.7: no `Makefile.am' found or specified

Googling the m4 error message turns up some chatter from circa 2002 which recommends upgrading to the then-latest automake or m4... this is automake 1.7.1 and GNU m4 1.4. GNU m4 1.4.1 came out recently, but it won't compile with MinGW out of the box so I haven't tried that yet.

Has anyone had this problem, or worked around it, or not had it at all? I'm compiling on Windows XP Home, with MinGW 3.1.0 and MSYS 1.0.10, the various packages from Tor's page, and a few bits stuffed in from GnuWin32.

-- brion vibber (brion @ pobox.com)

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to