Kurt Bigler <[EMAIL PROTECTED]> writes:

> Upon attempting to do this I ran into some problems and posted a
> question to the darwinports mailing list (because I currently build
> GTK+-2.0 via the darwinports "gtk2" port).  Someone replied to my
> query with the information that the GIMP application had achieved the
> application-bundle-relative situation that I have been trying to
> achieve.

See http://gimp-app.sourceforge.net/ (linked from
http://gimp.org/macintosh/). There's a script linked from that page
that is used to build the application bundle. That should answer your

> But for sure I have some "etc" problems.  These are the errors I am
> currently getting:
> > (scalamod:1650): GdkPixbuf-WARNING **: Can not open pixbuf loader
> > module file '/opt/local/etc/gtk-2.0/gdk-pixbuf.loaders': No such
> > file or directory

You need to run gdk-pixbuf-query-loaders to create this file. Usually
this is done when 'make install' is being run for gtk+.

> > Fontconfig error: Cannot load default config file
> > No fonts found; this probably means that the fontconfig
> > library is not correctly configured. You may need to
> > edit the fonts.conf configuration file. More information
> > about fontconfig can be found in the fontconfig(3) manual
> > page and on http://fontconfig.org

That error message contains the answer to your problem.

Gimp-developer mailing list

Reply via email to