I've updated the API docs on http://developer.gimp.org/api/2.0/ in
preparation of the 2.2.0 release. I will be doing another update when
the release is finally out. If someone wants to look over the docs and
fix/improve them, that would be very much appreciated. The focus
should be on the libgimp* documentation. The API docs for the core
(Gimp Application) are of minor importance.

One thing that I would really love to see being added is a guide that
shows people how to update their plug-ins for GIMP 2.2. It should
mention how to use GIMP_DISABLE_DEPRECATED in order to identify use of
deprecated API. Some infos on updates for GTK+-2.4 would probably be
helpful as well (links to the GTK+ reference manual would probably be

Gimp-developer mailing list

Reply via email to