i am attempting to build gimp from cvs.  updating and typing "make"
failed with the following error message:

./configure: line 33395: syntax error near unexpected token `1.0'
./configure: line 33395: `GTK_DOC_CHECK(1.0)'
make: *** [config.status] Error 2

the next step for me (usually) is to reconfigure.  i always send it a
few extra parameters, so i "./autogen.sh --help".  this failed with this
message:

checking for gtkdocize ... 
  You must have gtk-doc installed to compile The GIMP.
  Install the appropriate package for your distribution,
  or get the source tarball at
  http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/

so i went to the mentioned web site and snarfed the tarball.  to my
dismay, this is what i read about the new dependencies:

Requirements
============

Perl v5 - the main scripts are in Perl.
    http://www.perl.com/

DocBook SGML DTD v3.0 or DocBook XML DTD v4.1.2 - the DocBook DTDs.
    http://www.oasis-open.org/docbook/

Jade v1.1 or OpenJade 1.3.1 for SGML.
    http://www.jclark.com/jade
    http://sourceforge.net/projects/openjade

libxslt & libxml2 2.3.6 for XML.
    http://xmlsoft.org/

DocBook DSSSL Stylesheets (I've got 1.40, but v1.19+ may be OK)

DocBook XSL Stylesheets


is it a real fact that i need jade to build gimp or perhaps i am doing
something wrong?

is it only specific to cvs builds and if so is it a temporary thing?

does it make sense that i need jade to work on images with a piece of
free software that is not as free as jade or open jade?

i would like to build gimp without this additional (and un-needed by me)
software.

carol

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to