Irek Słonina wrote:

Andrei Simion wrote:

Hi again,

I managed to start X:

Xvfb :1.0 -screen 0 10x10x16

So, the display is 1.

Now, I start the Gimp server:

gimp --display 1 --no-interface --batch \('extension-perl-server 0 0 0'\)

and I get this error:

Invalid option "--display"

I tried different "--display" options: ":1", ":1.0", "1.0". The result
was the same.

I would guess that if you are using --no-interface then you can't use at
the same time --display... try to use --display to connect to Xvfb, but
without --no-interface.
I do not know if it will help you but I am running script-fu-server with
 following command:

/usr/bin/gimp -c -i -s -b '(plug-in-script-fu-server 1 10008
        \"/tmp/gimpserverlog\")' '(gimp-quit 1)' 1>/tmp/gimprunlog
        2>/tmp/gimperrlog &

Maybe try --display :1.0 -c -s, without no-interface.

Thanks Irek, I'll try your command. The thing is that the 1.3 version of gimp worked just fine with my command. To clear the things out: are you connecting to the Gimp server through some kind of interface or you work with the Gimp in the graphic mode?

Thanks again,
Andrei Simion

Gimp-developer mailing list

Reply via email to