On 8/26/05, Sven Neumann <[EMAIL PROTECTED]> wrote:
> Hi,
> 
> michael chang <[EMAIL PROTECTED]> writes:
> 
> >> 1. Make it possible to indicate that a plug-in requires GIMP 2.2
> >
> > 2.3, and 2.4 options would be nice here too, I suppose.  And also,
> > change the list of links of types to a drop down box, maybe?  (Dunno.)
> 
> 2.3 is a development version with no API guarantees whatsoever. The
> API is constantly changing and noone should be developing any plug-ins
> for it.

If you have such a closed Gimp Club attitude, why make developer
releases at all?  After all, all the members of the Gimp Club have cvs
accounts.  One of the most important reasons that we have preview
releases is so that when 2.4 is released, third-party plugins are
already available for it.  It's abundantly obvious that 2.3 is a
developer edition, with all that entails, and both users and plugin
developers are aware of the fact that things can break, but that
doesn't mean that it's counterproductive to track development and to
test the new features.  Would you prefer that serious problems in
newly added plug-in apis not be discovered until after they are
frozen?

Since 2.3 cvs contains a plugin that was originally maintained
separately, and GIMP was developed against gtk 1.3 long before API
freeze, it's obvious that you already know this, which makes me ask
the question: why did you say this in the first place?  Seriously, it
served no other purpose than discouraging people from testing the 2.3
series.  GIMP isn't exactly overwhelmed with volunteers. We should be
doing everything we can to encourage more people to try out 2.3, and
more people to be testing its new features.  Yes, that even includes
those features that have to be accessed programmatically.  Anyone who
is capible of developing a plugin against 2.3 is capible of fixing any
breakage if we change a non-frozen API.

> And 2.4 shouldn't be added before the 2.4 release.

That's a matter of taste.  After all, if 2.4 is backwards compatible
with 2.0 plugins, there are a ton of plugins that are already 2.4
compatible.  What's not a matter of taste is that plug-ins shouldn't
be marked as 2.4 compatible if they use non-frozen APIs.  After the
API is frozen is a different matter.

Rockwalrus
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.xcf.berkeley.edu
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to