Helmut Jarausch <[EMAIL PROTECTED]> writes:

> I've noticed that some ScriptFu scripts run just fine under 2.2.x but
> produce error messages under 2.3.5 (CVS)
> Is there a summary of API changes, possibly with hints for upgrading?

The API is supposed to be backward compatible. We will continue to
deprecate API and replace it with other functions but the old
functions will continue to work. Of course we might have accidentally
introduced a temporary API breakage. You should let us know how your
scripts break.

Please note that the development version by default warns about usage
of deprecated API. These are not error messages though, just hints
telling you that you should adapt your script to a new API.

Gimp-developer mailing list

Reply via email to