On Wed, 11 Jan 2006, Brannon King wrote:

> I'm sorry if this is a stupid question. Traditionally I'm a Windows 
> programmer though I dual boot Fedora for some rare uses. (I'm open to other 
> distro options!) I tried to compile GIMP 2.3.6 on FC4 the other day. That 
> didn't work: I needed the 2.8 GLIB stuff. I downloaded the source code, etc., 
> for it and compiled GLIB. That worked, but it installed it into usr/local and 
> the GIMP compile still fails. How do I make the GIMP compile read the 
> libraries from the correct location? And I'm not real sure the GLIB compile 
> used the right libraries. Any good references on the matter would be 
> appreciated.

You would have needed the latest glib,atk,pango and gtk

They should have been available from Red Hat? 

If they weren't you should have built them like

./configure --prefix-/usr

If you read ./configure --help you will see that unless you do this, it
will be built in /usr/local

Now that it is in /usr/local you need to set  enviroment variables so
that it picks up that library

Try (presume Fedora is sort of standard linux)

export LD_LIBRARY_PATH=/usr/local/lib:/usr/lib
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/:/usr/lib/pkgconfig/

That way it will look at /usr/local before /usr


Gimp-developer mailing list

Reply via email to