Hi list,

there is a problem with building GIMP on OS X since version 2.3.6 (2.3.5 still worked well). At the first look it seemed to be related to libtool, so I had a conversation with them. Peter gave me then some information that might help some enlighted gimp dev to wipe the problem out:


Anfang der weitergeleiteten E-Mail:

Von: Peter O'Gorman <[EMAIL PROTECTED]>
Datum: 19. Februar 2006 11:51:29 MEZ
An: Axel Wernicke <[EMAIL PROTECTED]>
Kopie: libtool@gnu.org
Betreff: Re: build problem related to libtool?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Peter O'Gorman wrote:
| Axel Wernicke wrote:
| | Hi list,
| |
| | while trying to build the latest development version of GIMP on OS X I | | got some errors. I tried to solve them with the gimp developers, but | | they told me that my problem is rather related to libtool then to the
| | gimp itself. That is why I'd like to ask for your help.
| | The command that crashes the make is:

The problem is here:
<http://cvs.gnome.org/viewcvs/gimp/app/Makefile.am?r1=1.355&r2=1.356>

I think they want to check for gnu binutils to use -rpath $ORIGIN/../lib, but I'm not sure. Right now they try to do this for OS != windows. Ick!

To make an app relocatable on Mac OS X, you have to do more work than this.
You need to link your libraries with an install_name (soname) of
@executable_path/../lib/libfoo.dylib, by far the easiest thing to do to make apps relocatable is to build as normal with -Wl,- headerpad_max_install_names ~ in LDFLAGS, then you can fix things to have the @executable_path/ bit after
build using install_name_tool(1).

Not libtool's fault, sorry, now you've got to go back to the gimp developers.

Peter

btw. there is a complete build log at http://wernicke-online.net/temp/ gimp2.3.7_build.log

hope that helps!

I'd really like to see GIMP running on OS X in the dev version.

Greetings, lexA
---
Live is like a chocolate box, you never know what you wanna get...
GPG Signatur auf http://wernicke-online.net/Impressum/ prüfen

Attachment: PGP.sig
Description: Signierter Teil der Nachricht

_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to