On Sun, Apr 16, 2006 at 08:10:54PM +0200, Zephyr wrote:
> Hello,
> I wanted to compile My Very Own GIMP From CVS (TM) and play with the
> code, explore it etc. As it should be just my playground, I don't want
> to install it system-wide and possibly endanger my stable GIMP 2.2.10
> installed from RPM. So I made directory (my $HOME is /home/zephyr):
> 
> /home/zephyr/Projects/gimp-cvs
> 
> where I made CVS checkout. In this directory I created another one :
> 
> MY-USR-LOCAL
> 
> and ran
> 
> ./autogen.sh --prefix=/home/zephyr/Projects/gimp-cvs/MY-USR-LOCAL
> make
> make install
> 
> The configuration and compilation  went hapilly, but "make install"
> eventually failed:
> 
> Making install in libgimpconfig
> make[1]: Entering directory
> `/home/zephyr/Projects/gimp-cvs/libgimpconfig'
> make[2]: Entering directory
> `/home/zephyr/Projects/gimp-cvs/libgimpconfig'
> test -z "/home/zephyr/Projects/gimp-cvs/MY-USR-LOCAL/lib" || mkdir -p --
> "/home/zephyr/Projects/gimp-cvs/MY-USR-LOCAL/lib"
>  /bin/sh ../libtool --mode=install /usr/bin/install -c
> 'libgimpconfig-2.0.la'
> '/home/zephyr/Projects/gimp-cvs/MY-USR-LOCAL/lib/libgimpconfig-2.0.la'
> libtool: install: error: cannot install `libgimpconfig-2.0.la' to a
> directory not ending in /usr/local/lib
> make[2]: *** [install-libLTLIBRARIES] Error 1
> make[2]: Leaving directory
> `/home/zephyr/Projects/gimp-cvs/libgimpconfig'
> make[1]: *** [install-am] Error 2
> make[1]: Leaving directory
> `/home/zephyr/Projects/gimp-cvs/libgimpconfig'
> make: *** [install-recursive] Error 1
> 
> The relevant error extracted from this is:
> 
> libtool: install: error: cannot install `libgimpconfig-2.0.la' to a
> directory not ending in /usr/local/lib

Sounds like you first built without specifying a --prefix. You need to
run "make clean" and then rebuild.

-Yosh
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to