Carol Spears wrote:
On Thu, May 04, 2006 at 06:45:32PM -0500, Jim Sabatke wrote:
I have been updating all my machines to gimp 2.2.10. It works fine on all of them except for my HP ZD 7000 laptop. 2.2.0 worked fine on this box. I'm getting the infamous wire_read error whenever I try to open a file. I've googled for some time and there seem to be countless solutions, none of which work for me. The error I get is:


Segmentation fault
[EMAIL PROTECTED]:~/programs/media/gimp-2.2.10>
(script-fu:8117): LibGimpBase-WARNING **: script-fu: wire_read(): error

that is a message that is sent by a healthy script-fu server when gimp
crashes.

i wonder if your gimp is using the old gimp libraries.

did you build this gimp yourself or did your distribution install it?

one quick way to check to see if it is using the wrong library is to:
[EMAIL PROTECTED]:~> whereis gimp

and
[EMAIL PROTECTED]:~> whereis libgimp

if you have some gimp stuff in /usr/lib and also in /usr/local/lib that
would be what is making the crash.

if you still have the gimp-2.2.0 sources around, as root, "make
uninstall"  and then in the new gimp-2.2.10 sources, "make install"
again.

let me know how this goes

carol



Here's some more info. I ran gcc on it and here is the debug info after trying to open a file:

[Switching to Thread 16384 (LWP 14365)]
0x401f6595 in error_message_with_parent (parent=0x0,
    msg=0x8bfcdb8 "Could not retrieve information about the file",
    detail=0x8bfce20 "error accessing 'file:///home/jim': Invalid URI")
    at gtkfilechooserdefault.c:962
962       if (parent->group)


Jim

_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to