Hello again!

I don't find any solution yet. Seems like signal.h is not included - but why?
If anybody need more information or clarification to help in this problem, please tell me.

Thanks in advance,

Haarald


On 7/1/06, Haarald Sinihammas <[EMAIL PROTECTED]> wrote:
Well, now i can post exact info:

Configure command is:
./configure LDFLAGS=-L/usr/local/lib CFLAGS=-I/usr/local/include/ CPPFLAGS=-I/usr/local/include/

if i doing gmake, then i get for last:

 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DXTHREADS -DXUSE_MTSAFE_API -I/usr/local/include/atk- 1.0 -I/usr/local/include/cairo -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/X11R6/include/gtk-2.0 -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include -I/usr/local/include/freetype2 -I/usr/local/include -I/usr/local/include -DG_LOG_DOMAIN=\"LibGimp\" -D_REENTRANT -I/usr/local/include/glib- 2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/ -DGIMP_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -I/usr/local/include/ -Wall -MT gimp.lo -MD -MP -MF .deps/gimp.Tpo -c gimp.c  -fPIC -DPIC -o .libs/gimp.o
gimp.c: In function `gimp_main':
gimp.c:340: error: `SIGBUS' undeclared (first use in this function)
gimp.c:340: error: (Each undeclared identifier is reported only once
gimp.c:340: error: for each function it appears in.)
gimp.c:349: error: `SA_RESTART' undeclared (first use in this function)
gimp.c: In function `gimp_extension_process':
gimp.c:1335: error: syntax error before "readfds"
gimp.c:1349: warning: implicit declaration of function `FD_ZERO'
gimp.c:1349: error: `readfds' undeclared (first use in this function)
gimp.c:1350: warning: implicit declaration of function `FD_SET'
gimp.c:1352: warning: implicit declaration of function `select'
gimp.c:1352: error: `FD_SETSIZE' undeclared (first use in this function)
gimp.c: In function `gimp_plugin_sigfatal_handler':
gimp.c:1475: error: `SIGBUS' undeclared (first use in this function)
gmake[2]: *** [ gimp.lo] Error 1
gmake[2]: Leaving directory `/usr/home/zwoz/Desktop/Downloads/gimp-2.3.9/libgimp'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/home/zwoz/Desktop/Downloads/gimp-2.3.9'
gmake: *** [all] Error 2


_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to