I had earlier asked how to do CVS so that, as a user, I could have the
latest version and could have a greater chance of commenting
semi-intelligently on UI issues. Some of you were kind enough to
point me in the right direction.

After about 5 hours over a dialup connection, I managed to get the
CVS. Then it wanted intltool, and I found and installed that.  It also
wanted gtk-doc, but I wasn't able to make that for some error I can't
remember, (something about missing stylesheets - sorry, I am sending
from a different place and don't have the info with me...). So I used
the --disable-gtk-doc flag that it suggested. However, ./autogen.sh
still gives me error messages which my inexperience does not allow me
to understand.

Thanks if anyone can point me in the proper direction, bearing in mind
that I am not a wizard at make or any of these tools. I did look at
the info '(automake1.8)...' which was suggested, and it was entirely
over my head.

My apologies if this duplicates a post I sent earlier from a
non-registered address which appears not yet to have materialized.

scott swanson

Here is the output from ./autogen.sh:

I am testing that you have the tools required to build the
GNU Image Manipulation Program from CVS. This test is not foolproof,
so if anything goes wrong, see the file HACKING for more information...

checking for libtool >= 1.4 ... yes (version 1.5.20)
skipping test for gtkdocize
checking for autoconf >= 2.54 ... yes (version 2.59)
checking for automake >= 1.8.3 ... yes (version 1.9.6)
checking for glib-gettextize ... yes (version 2.12.3)
checking for intltool >= 0.31 ... yes (version 0.35.0)
checking for xsltproc ... yes

I am going to run ./configure with the following arguments:

  --enable-maintainer-mode  --disable-gtk-doc 2

/usr/local/share/aclocal/parted.m4:16: warning: underquoted definition of 
  run info '(automake1.8)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/local/share/aclocal/avifile.m4:21: warning: underquoted definition of 
aclocal:configure.in:416: warning: macro `AM_PATH_GTK_2_0' not found in library
WARNING: You have disabled gtk-doc.
         As a result, you will not be able to generate the API
         documentation and 'make dist' will not work.

configure.in:426: error: possibly undefined macro: AM_PATH_GTK_2_0
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Gimp-developer mailing list

Reply via email to