I had gimp-cvs installed in /opt/gimp and wanted to use gimp-2.2 to print some photos. I was getting errors starting gimp-2.2 so I ran make install on gimp-cvs but 2.2. failed to start thowing up half a dozen errors.

 $ gimp
GIMP: Error while parsing '/home/prof/.gimp-2.3/gimprc' in line 11: invalid valu
e 'lanczos' for token interpolation-type

GIMP: There was an error parsing your 'gimprc' file. Default values will be used . A backup of your configuration has been created at '/home/prof/.gimp-2.3/gimpr

(gimp:23640): GLib-GObject-WARNING **: cannot register existing type `GimpConfig

(gimp:23640): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: asser
tion `G_TYPE_IS_INTERFACE (interface_type)' failed

(gimp:23640): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `
g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(gimp:23640): GLib-GObject-WARNING **: cannot register existing type `GimpConfig


The cause is pretty clear but why is it using the gimprc in .gimp-2.3 ?! There is alsa a .gimp-2.2 for this user but it taking a directory specifically named as another version.

Having deleted both the .gimp* configs I restart 2.2 and get the orange dlg "Gimp user installation" that tells me it needs create "a folder named /home/user/.gimp-2.3" . YES gimp 2.2 wants to install it's config as gimp-2.3 .

What is the mechanism leading to this error?

Thanks for any clarification.
Gimp-developer mailing list

Reply via email to