On Tue, Feb 06, 2007 at 08:38:31AM +0100, Sven Neumann wrote:
> Hi,
> 
> On Mon, 2007-02-05 at 22:38 +0100, Marco Ciampa wrote:
> > I just noted this strange behaviour: when I see the the 
> > Image menu->View->Display filters->Color Deficient Vision options
> > (Protanopia, Deuteranopia, Tritanopia) with the Italian locale, _all_ but
> > these three options are translated. Is it my svn copy fault or does it have 
> > this
> > behaviour in other languages too?
> 
> Sorry, but I don't understand your question. 
Sorry for my bad english...

> What's translated and what's not? 
The problem seems around the option pulldown menu...

> And did you already check in the it.po files that the
> strings have been translated at all?
Of course, the it.po file is correctly translated.

Maybe I have some problems in the configure procedure?

running ./configure & make I get:

make
[...]
Making all in gui
make[3]: Entering directory `/home/marco/svn-gnome/gimp/trunk/app/gui'
if gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../.. -I../../app
-I../../app -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I/usr/local/include
-DG_LOG_DOMAIN=\"Gimp-GUI\" -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -DGIMP_DISABLE_DEPRECATED
-DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED
-DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED
-DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE  -g -O2 -Wall
-Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations
-Winit-self -Wpointer-arith -MT gui.o -MD -MP -MF ".deps/gui.Tpo" -c -o
gui.o gui.c; \
        then mv -f ".deps/gui.Tpo" ".deps/gui.Po"; else rm -f
".deps/gui.Tpo"; exit 1; fi
In file included from /usr/include/dbus-1.0/dbus/dbus-glib-lowlevel.h:28,
                 from gui.c:27:
/usr/include/dbus-1.0/dbus/dbus.h:30:2: error: #error "Please define
DBUS_API_SUBJECT_TO_CHANGE to acknowledge your understanding that D-Bus
/hasn't reached 1.0 and is subject to protocol and API churn. See the README
for a full explanation."
make[3]: *** [gui.o] Error 1
make[3]: Leaving directory `/home/marco/svn-gnome/gimp/trunk/app/gui'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/marco/svn-gnome/gimp/trunk/app'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marco/svn-gnome/gimp/trunk'
make: *** [all] Error 2

I'm able to compile again inserting

#define DBUS_API_SUBJECT_TO_CHANGE

in app/gui/gui.c

but I do not think this is the correct way I should follow to compile...

Resolving this error I get another error:

Making all in po-libgimp
make[2]: Entering directory `/home/marco/svn-gnome/gimp/trunk/po-libgimp'
Makefile:159: *** target pattern contains no `%'.  Stop.
make[2]: Leaving directory `/home/marco/svn-gnome/gimp/trunk/po-libgimp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marco/svn-gnome/gimp/trunk'
make: *** [all] Error 2

Exaclty on the po files where I see the problem, perhaps resolving this
fixes it all...


-- 

Marco Ciampa

+--------------------+
| Linux User  #78271 |
| FSFE fellow   #364 |
+--------------------+
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to