On Fri, 2007-05-25 at 17:56 +1000, David Hodson wrote:

> Should be all gimp-2.2, AFAIK. I'll ask him to check that everything 
> matches.

I've checked gimptool-2.0 in the 2.2 branch and indeed the --libs output
was missing the appropriate linker flags to also link against
libgimpmodule. Since libgimpui uses symbols from libgimpmodule, plug-ins
also need to link against it. I have now fixed this oversight in the
gimp-2-2 branch and 2.2.15 (to be released soon) will have this fix.

I recommend though that you change your Makefile to use pkg-config
instead of gimptool-2.0. The syntax is very similar and pkg-config is
well established nowadays.

So instead of using
  gimptool-2.0 --cflags --libs
please use
  pkg-config --cflags --libs gimpui-2.0


Gimp-developer mailing list

Reply via email to